Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Work notes are showing an incorrect author - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Work notes are showing an incorrect author
KB0749125

Work notes are showing an incorrect author


797 Views Last updated : Jul 9, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Work notes on certain records appear to have an incorrect author.

Release

All releases

Cause

Work notes can show up as having been posted by the wrong user when auditing data is corrupted or missing.  

Resolution

Make sure auditing is turned on for the table which is experiencing the issue, and this will ensure that the issue does not reoccur in the future.  To verify this, navigate to the sys_dictionary table, find the entry for the table in question and check the "audit" checkbox.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.