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vaSystem.connectToAgent() method is causing an error if no agents are avaliable in Workspace Chat queue - Support and Troubleshooting
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KB0749042

vaSystem.connectToAgent() method is causing an error if no agents are avaliable in Workspace Chat queue


3396 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

When trying to transfer a Virtual Agent topic to a chat queue (Agent Workspace Chat, not Connect Support), no message is shown and there is an error in the logs with a similar call stack to this one.

vaInputs.__silent_ScriptedAction_7a4e74622d394259a62af46a871840d0=true;null; Root cause of JavaScriptException: com.glide.cs.qlue.module.runtime.expression.TopicException : com.glide.cs.qlue.module.runtime.expression.TopicException: undefined: com.glide.cs.qlue.module.taco.ConversationServiceImpl.initiateConnectToAgent(ConversationServiceImpl.java:449) com.glide.cs.qlue.module.runtime.script.SystemScriptObject.jsFunction_connectToAgent(SystemScriptObject.java:109)

Release

Madrid

Cause

There are no agents avaliable in the queue.

Resolution

To prevent this from happening you should first check that agents are available using the vaSystem.isLiveAgentAvailable() method. 

Here is an example of how to do this from the Documentation.


if (vaSystem.isLiveAgentAvailable() ) {
vaSystem.connectToAgent()
}

Additional Information

https://docs.servicenow.com/csh?topicname=transfer-to-live-agent.html&version=latest


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