Issue
Error and Info messages raised by server-side business rule is automatically disappearing. A business rule is displaying error and info messages using the functions:
gs.addErrorMessage()
gs.addInfoMessage()
The functions are documented below:
Release
All Versions
Cause
There script part of the UI Policy contained the below function:
g_form.clearMessages()
The UI Policy was being triggered and the function was being executed.
Please see the following documentation:
https://docs.servicenow.com/csh?topicname=c_GlideFormAPI.html&version=latest#c_GlideFormAPI
Resolution
Inactivate/Re-evaluate the UI Policy so that the error/info messages remains at top of the form until closed by the user.