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Symptoms

When trying to go to the password reset page via the password reset URL you get the following message:

"We could not reset your password because we cannot connect to the Active Directory server. Try again later"

Release

Any

Cause

The error is on the $pwd_error UI page in the following line:

<j:when test="${jvar_error == 'midserver_not_running'}"> 
<h2 class="pwd-subtitle">${gs.getMessage('We could not reset your password because we cannot connect to the Active Directory server. Try again later.')}</h2> 
</j:when> 

The error is "midserver_not_running". 

Resolution

  1. Make sure the MID server is running, and in an 'Up' state.
  2. Make sure the MID server has the 'supported applications', 'capabilities', and 'IP ranges' configured properly.

Additional Information

MID Server selection - MID Server criteria

Article Information

Last Updated:2019-05-21 11:58:17
Published:2019-05-13