Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Requested Items widget does not display the name of the requested item - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Requested Items widget does not display the name of the requested item
KB0748666

Requested Items widget does not display the name of the requested item


1074 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Requested Item widget displays the RITM number but not the name of the requested item.

 

Release

All supported versions.

Cause

On a very specific level, this issue is caused by missing value for options.display_field

The reason why this might be missing?

On the OOB page, this is configured properly but when this widget is added to other pages, this property needs to be configured on the widget instance.

Resolution

Fixing from widget instance:

  1. Go to the corresponding instance for the widget.
  2. Make sure that the instance type is Instance of Simple List.
    • This will make sure that the following two fields are available to configure on the instance.
  3. Set the table to Requested Item [sc_req_item].
  4. Set the display field to Short description.
    • This is what get's displayed as the name of the requested item.
  5. Save

Additional Information

If for some reason you can't change the type of instance to "Instance of Simple List" and fields Table and Display field is not available on the widget instance, then you can pass this value from the JSON parameters, paste the following in the Additional Options section:

{
    "display_field": {
        "displayValue": "short_description",
        "value": "short_description"
    }
}

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.