Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Ecc queue returs HTTP status 0 if the payload exceeds maximum size - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Ecc queue returs HTTP status 0 if the payload exceeds maximum size
KB0748591

Ecc queue returs HTTP status 0 if the payload exceeds maximum size


4431 Views Last updated : Jan 15, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When REST call is made through MID server you will see HTTP status returning as 0 and you can see below error in ECC queue.

Payload size of 41047892 bytes exceeded maximum of 20000000 bytes.
Contents of the original payload were moved to C:Dev Servermid.istanbul-09-23-2016__patch6-05-02-2017_05-19-2017_1034.windows.x86-64agentworkmonitorsECCSenderoutput_oversizeecc_queue.66daa695dbbea78064d87d8bbf961930.xml on the MID server.
Maximum payload size can be set with mid config parameter: mid.eccq.max_payload_size

Release

All

Cause

The limitation set in the system property mid.eccq.max_payload_size.

Specifies the maximum string length of a payload that the MID server sends to the instance. The MID Server verifies the size of the payload before sending it to the instance, If the payload size exceeds the limit, the MID Server discards it and returns an error message in the payload.

Resolution

1) Go to MID Server > Select the MID server where the REST call is going through> Under the related list, go to MID Properties.

2) Check if the property mid.eccq.max_payload_size does exist.

3) If the property exists, increase the size of the payload in bytes, if it doesn't exist create new and specify the payload size in bytes, default is 20000000 bytes.

OR

1) you can also configure this as a configuration parameter on an individual MID Server

2) Please follow the below documentation to configure the parameter on specific MID Server

https://docs.servicenow.com/csh?topicname=mid-server-parameters.html&version=latest#t_SetMIDServerParameters


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.