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In the knowledge article list view, searching in the Category field doesn't return results when using languages other than English - Support and Troubleshooting
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  • In the knowledge article list view, searching in the Category field doesn't return results when using languages other than English
KB0748558

In the knowledge article list view, searching in the Category field doesn't return results when using languages other than English


1714 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

When searching the field look up for a category field on the knowledge table with a user language, for example, Spanish, no results are shown. The issue happens only with the Category field (Reference type) in the kb_knowledge table and not any other reference type fields in the same or other tables.

The search results show up only if the category is created in that language and doesn't show up in other languages.

Steps to reproduce:

In an affected instance:

  • Activate the plugins I18N:Knowledge Management Internationalization v2 plugin and Spanish Translation
  • Navigate to kb_knowledge.list
  • Search for a category field in the list view
  • Observe that the results show up
  • Switch the language to Spanish
  • Now search the same category field in the list view
  • Observe that no results show up in Spanish language

Actual behavior: No results show up on searching the category field in Spanish language

Expected behavior: Same results show up on searching the category field in Spanish language as it does when using English language

Release

At least Kingston and London

Cause

A field of the type "Translated Text" allows the same field to display different content based on the user's language.
In the "Category(kb_category)" table, the field "Label" is a Translated-Text. So any customized categories are not automatically translated and have to be manually done by creating a translated text label for the customized category.

Resolution

To create a translated text for the category in the kb_category table follow the steps given below:

  1. Navigate to sys_translated_text.list
  2. Create a new translated text
  3. Select the table name: kb_category
  4. Select language: Spanish
  5. Select Field name: label
  6. In the documents field again select the table kb_category
  7. Select the English category you want to translate
  8. Write the Spanish translation of that category in the values field.
  9. Submit

Observe that the category gets translated to the language chosen by the user.

Additional Information

Translate the content of a translated text field


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