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SCCM integration - Test data source connection or any other import specific action fails with error: Failed to init the JDBC connection. Check configuration. - Support and Troubleshooting
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  • SCCM integration - Test data source connection or any other import specific action fails with error: Failed to init the JDBC connection. Check configuration.
KB0748493

SCCM integration - Test data source connection or any other import specific action fails with error: Failed to init the JDBC connection. Check configuration.


1991 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

The error 'Failed to init the JDBC connection. Check configuration' is seen during any of the below actions-

  • Form the SCCM integration's 'setup' page, if 'Test data source connection' is performed.
  • If 'Load 20 records' is performed from any of the SCCM integration's data source page.

The investigation process below is for a specific condition where the error 'Failed to init the JDBC connection. Check configuration' is seen and the MID server records the below error-

SOAPProcessingException: Field(s) present in the query do not have permission to be read

Below is the snapshot from MID server agent log and if you have a closer look, here is what you find-

  • Initially, you would observer the error 'Failed to init the JDBC connection. Check configuration' for JDBC probe attempt.
  • Eventually, you would observe 'SOAPProcessingException: Field(s) present in the query do not have permission to be read' multiple times throughout. 

Release

  • Any Release.

Steps to Reproduce

  • Hop on to the instance.
  • Navigate to setup under 'Integration - Microsoft SCCM 2016'
  • On the left pane, there is a related link for 'Test data source connection' click that to see that the attempt ends with an error 'Failed to init the JDBC connection. Check configuration.'

Cause

  • This condition is observed because of insufficient privileges to the MID Server User on the instance.

Resolution

After reproducing the issue successfully, to resolve the issue, follow the below steps

  • On the instance, for the relevant MID server that is being used for the SCCM integration, take note of the MID user(Logged in user).
  • Navigate to user administration --> Users, find the user and open the user record.
  • Edit the Role permissions and double check to see if 'mid_server' role is added. 
  • Cross check to see if these roles are present - soap, soap_query, soap_update, soap_delete, soap_create, soap_ecc, soap_script.
  • If any of the above roles are missing, please add them.

Post adding the roles, a validation can be done by performing 'Test data source connection' and you should see 'connection successful' message.


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