Issue
Symptoms
- When clicking the "Change Schedules" module (Change > Schedules > Change Schedules) and navigating to Change Schedules, the page opens, but all that is seen is that the page is infinitely "Loading..." and nothing happens
- In the browser console, the user sees the following error:
Failed to load resource: the server responded with a status of 500 (Internal Server Error)
followed by "REST Failure"
Release
- London Patch 5
- London Patch 6a
Cause
Not all Change Schedule Definitions have a value in the "Owner" field.
Resolution
In order to resolve the behavior, simply populate all Change Schedule Definition's "Owner" field with a value.
After doing this, the Change Schedule page will load perfectly, and the browser console error will no longer display.