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Issue

Symptoms

Users cannot search articles on the Knowledge homepage even though they have access

Knowledge article search results is none

Release

Any

Environment

Any

 

Cause

The root cause of the issue is that the 'Requires role' ACL for AngularProcessor^ContextSearchService and AngularProcessor^message are missing the snc_internal role.

https://<instance>.service-now.com/nav_to.do?uri=%2Fsys_security_acl.do%3Fsys_id%3D193d6a93d7210200bef20ee60e6103fc

https://<instance>.service-now.com/nav_to.do?uri=%2Fsys_security_acl.do%3Fsys_id%3D198daa93d7210200bef20ee60e6103c7

 By default, the ACL should have the snc_internal role.

 

Resolution

Add the snc_internal role to this ACL

Make sure that the user having issue has all the roles listed on the ACL if you have customised it

 

Article Information

Last Updated:2019-08-02 20:44:24
Published:2019-05-05