Issue
Symptoms
Users cannot search articles on the Knowledge homepage even though they have access
Knowledge article search results is none
Release
Any
Environment
Any
Cause
The root cause of the issue is that the 'Requires role' ACL for AngularProcessor^ContextSearchService and AngularProcessor^message are missing the snc_internal role.
By default, the ACL should have the snc_internal role.
Resolution
Add the snc_internal role to this ACL
Make sure that the user having issue has all the roles listed on the ACL if you have customised it