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Following a link to a survey redirects to a null page after SSO authentication - Support and Troubleshooting
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KB0748137

Following a link to a survey redirects to a null page after SSO authentication


952 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

When a user follows a link to a survey (for example, by clicking the link in an email) and the instance has SSO authentication enabled, after authenticating, they are redirected to a null page, Page Not Found

The URL might be something like <instanceName>.service-now.com/nav_to.do?uri=%2Fnull

Release

All releases.

Cause

When SSO authentication is enabled, if the assessment_take2 page is a public page, the link to the survey won't work.

Resolution

Make the assessment_take2 page a non-public page:

1. In the Application Navigator, enter sys_public.list
2. Filter the Page column for starts with assessment.
3. You should see 2 matching records, one for assessment_take2 and another for assessment_thanks.

4. Modify the Active value for the assessment_take2 public page to false.
5. Leave the Active value true for the assessment_thanks public page.


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