Issue
Symptoms
SLAs are not getting attached to new Incidents created even when the SLA definitions seem relevant and the relative conditions satisfied.
Cause
Incidents are being created new, but with State already set to Resolved, which invalidates the SLA condition and eventually does not trigger any SLA.
Resolution
Once a new Incident form is opened, make sure to first switch the State to any value other than Resolved, Closed, or Cancelled.