Issue
Symptoms
Variable value is cleared on RITM and SC Task variable editor after the item is submitted
Release
London and forward
Cause
There is a UI Policy which has an action that clears the variable value. A new feature introduced in London.
Resolution
Uncheck the "Clear the variable value" checkbox
Additional Information
https://docs.servicenow.com/csh?topicname=t_CreatUIPolicyForSvcCalgIt.html&version=latest