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Dashboard Interactive filters preferences are not saved - Support and Troubleshooting
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  • Dashboard Interactive filters preferences are not saved
KB0748065

Dashboard Interactive filters preferences are not saved


4062 Views Last updated : Mar 11, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When applying the interactive filter on any dashboard and the filter is applied but the filter choices are not stored in preferences, when navigating back to the dashboard the widgets are loaded with the default filters.

Steps to reproduce:

  1. Impersonate the affected user.
    2. Open any Dashboard with interactive filters.
    3. Apply interactive filters.
    4. Navigate away from the dashboard.
    5. Navigate back and note the interactive filter is set back to default.

Release

All current releases that have the com.snc.read_only.role plugin enabled.

Cause

  1. Any user assigned with the role snc_read_only will experience this issue.
    2. Please review the documentation: Read-only role
     Note: After you assign this role to a user, they can no longer create, update, or delete records on ANY table.

Resolution

  1. There are system properties that can be configured to grant access to a specific table to users with read only roles:
    • glide.security.snc_read_only_role.tables.exempt_create
    • glide.security.snc_read_only_role.tables.exempt_write
    • glide.security.snc_read_only_role.tables.exempt_delete
  2. There are some default values that are already part of the exempted table list as explained in the documentation: Read-only role properties

To resolve this issue:

  1. Add the table sys_canvas_preferences to the default list of tables on the properties mentioned above.
 Note: If the system properties do not exist, you can create them by adding them to the sys_properties table. Please ensure you add all the default tables and sys_canvas_preferences to the system properties mentioned above.

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