Issue
Unable to change the value of a variable within a Catalog Task
Release
ALL
Cause
In this case, the behavior experienced is due to a UI Policy which is setting the variable to read-only (a Client Script can cause the same kind of behavior). Hence, the value cannot be changed/edited.
Resolution
If it is required that the variable value be modifiable, the user can either make the UI Policy active false or place some condition upon it whereby the variable is read-only to a select group of users and editable to another group of users - whatever best meets the business needs of the user.