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Empty variables on RITM's when created through Service Portal - Support and Troubleshooting
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  • Empty variables on RITM's when created through Service Portal
KB0747577

Empty variables on RITM's when created through Service Portal


4440 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When submitting a catalog item from Service Portal, you may notice that some of your Requested Item records have missing variable:

Cause

When using server.update() in the customized Catalog Item widget, this re-initializes the catalog form.

Once the variable values are filled for a catalog item in Service Portal, these values are stored in the angular scope. However, when you perform a server.update() after filling in these variables, the Server script is rerun and restarts the form. 

NOTE: After calling server.update() the client script’s data object is automatically overwritten with the server’s data object.

Since these variables values in DOM and $scope are single way bound, the end user will still see the values on Catalog Form UI, but when submitting, a new Catalog item form will be sent, initialized by server.update(), thus, fulfillers will see empty RITMs created without any values.

 

Resolution

Switch to OOB SC Catalog Item widget by following the steps below:

  1. Navigate to <yourInstance>.service-now.com

  2. Navigate to sp_page_list.do

  3. Filter by Page ID, here it is “sc_cat_item”

  4. Open the widget instance associated to the SC Catalog Item Widget

5. In the widget instance record, change the widget field from Custom SC Catalog Item widget to SC Catalog Item Widget

 

Alternatively, you can add a conditional wrapper around the OOB Server Script for SC Catalog item widget:

(function () {
// Server Code of the SC Catalog Item widget

if(input.<variable>){ //<variable> place holder for input variable object

//--  Perform the action initiated from the client

//--  Custom feature

} else {

//--  OOB SC Catalog Item code

}
})()


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