Issue
Symptoms
When a user logs in (just once, only creating one session), and then opens up a second tab or window, the navigation activity from one tab will affect the navigation activity on the second tab. The user may experience interfering navigation sequences when using the ServiceNow back button.
The same problem occurs If the user logs in multiple times in different tabs or windows (creating multiple session IDs)
Release
All
Cause
The ServiceNow back button uses the cache memory stored in the user's machine, therefore it doesn't make a distinction even if there are different session IDs active.
Resolution
To avoid this, the user can use the browser's back button instead. Alternatively, if the user still wants to use the ServiceNow back button, they can use a private browsing session window in conjunction with a normal browsing session window.