Issue
A user is unable to delete a Time Sheet Policy.
Cause
The default policy is applied and it is read-only.
Resolution
- Log in as a user with the "timecard_admin" role
- Navigate to the Time Sheet Policies: /nav_to.do?uri=%2Ftime_sheet_policy_list.do%3Fsysparm_clear_stack%3Dtrue
- Open the record you want to delete
- Right-click on the field label "Default Policy"
- Select Configure Dictionary
- This will bring you to the dictionary entry of the field
- Uncheck "Read-only" and save
- Open the Time Sheet record again and uncheck "Default Policy"
- Save the record and then try to delete it