Issue
Symptoms
When a RITM was canceled, the status was changed from 'Closed' to 'Under Fulfillment' and sub-status was changed from 'Cancelled' to empty.
Release
Madrid Patch 1 Hot Fix 2
Cause
Custom business rule was created to cancel the workflow context of the RITM; however, it was not canceling the context and the workflow was updating the RITM after the approvals were canceled.
Resolution
Corrected the custom business rule to cancel the workflow context when the RITM is canceled.
var w = new Workflow();
var gr = new GlideRecord('wf_context');
if (gr.get(current.context))
w.cancelContext(gr);