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Knowledge block user criteria is not working as expected - Support and Troubleshooting
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  • Knowledge block user criteria is not working as expected
KB0747389

Knowledge block user criteria is not working as expected


1647 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Certain users can see all Knowledge blocks even when the applied user criteria (UC) do not apply to them.

Release

London Patch 4, Hot Fix 2

Cause

The reason both User A and User B are able to see all blocks is that they possess the roles needed to pass the "Can Contribute" user criteria on the Knowledge Bases to which those blocks belong.

Resolution

As shown in the following diagram, if User A, User B, or any other user have Can Contribute access at the Knowledge Base level, they can read the block straight away, without issue.

All of the user's Knowledge blocks are contained in one of two Knowledge Bases, either:

  • User A's Knowledge Base, or (Can Contribute: mu_business_personnel, mu_business_solvers, mu_servicedesk)
  • User B's Knowledge Base (Can Contribute: anyone (no roles listed))

The reason that both users can see everything in User B's Knowledge blocks is that there is no "Can Contribute" user criteria on the Knowledge Base level. Therefore, all users pass (see diagram) and can read the content of the Knowledge blocks in it.

The reason that bot users can see all the blocks residing in the User A's Knowledge Base is that they have the necessary roles for "Can Contribute" and, again, bypass any criteria on the block level. User A has "mu_business_solvers" and User B has "mu_business_personnel".

The shown behavior is expected.

Additional information

Select user criteria for a knowledge block


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Attachments

Attachments

  • knowledge-block-user-criteria-flow.png

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