Issue
Cannot Load Video Files to KB Articles
After uploading and saving, the video on an Article disappears
Cause
The issue is most likely due to the HTML being sanitized
Resolution
Option #1:
- Navigate to System Definition ➔ Dictionary
- Click the Edit Filter button
- In the filter, you need two conditions. First you need ["Column name" "starts with" "text"] and second you need ["Table" "is" "kb_knowledge"]
- Open the single record that is displayed on the list
- Click the "Advanced view" User Interface action under the related links
- In the attributes field, add ", html_sanitize=false" to the end of the other attribute listed. Include the comma
- Re-upload the video and save the form. It should now be displayed properly.
Option #2:
Make this below changes on the instance to fix the issue:
- Go to the Dictionary of field 'Article Body' (text) and Add an attribute to the text field on the form that the video is added to:
html_sanitize=false. Adding the attribute stops this HTML field from being sanitized in the future. - Modify the white list in the script include HTMLSanitizerConfig to add the embed, object, and param attributes. The script include allows the attributes to be used in all HTML fields in the future.
For example: HTML_WHITELIST :{ globalAttributes:{ attribute:[], attributeValuePattern:{} }, embed:{attribute:["src","type","allowfullscreen","allowscriptacces","plugnspage"]}, object:{attribute:["classid","codebase"]}, param:{attribute:["name","value"]} } - Universally override elements that the TinyMCE strips out by adding a list of elements to the glide.ui.html.editor.extended_valid_elements property.
For example: adda[onclick|href|target|rel|media|hreflang|type|charset|name|rev|shape|coords|download|id|accesskey|class|dir|lang|style|tabindex|title]to the system property.
Related Links
Videos in the knowledge article are missing or unable to play