Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Cannot Load Video Files to KB Articles - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Cannot Load Video Files to KB Articles
KB0746332

Cannot Load Video Files to KB Articles


986 Views Last updated : Feb 23, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Cannot Load Video Files to KB Articles

After uploading and saving, the video on an Article disappears

Cause

The issue is most likely due to the HTML being sanitized

Resolution

Option #1:

  1. Navigate to System Definition ➔ Dictionary
  2. Click the Edit Filter button
  3. In the filter, you need two conditions. First you need ["Column name" "starts with" "text"] and second you need ["Table" "is" "kb_knowledge"]
  4. Open the single record that is displayed on the list
  5. Click the "Advanced view" User Interface action under the related links
  6. In the attributes field, add ", html_sanitize=false" to the end of the other attribute listed. Include the comma
  7. Re-upload the video and save the form. It should now be displayed properly. 

Option #2:

Make this below changes on the instance to fix the issue:

  1. Go to the Dictionary of field 'Article Body' (text) and Add an attribute to the text field on the form that the video is added to:
    html_sanitize=false. Adding the attribute stops this HTML field from being sanitized in the future.

  2. Modify the white list in the script include HTMLSanitizerConfig to add the embed, object, and param attributes. The script include allows the attributes to be used in all HTML fields in the future.
    For example: HTML_WHITELIST :{ globalAttributes:{ attribute:[], attributeValuePattern:{} }, embed:{attribute:["src","type","allowfullscreen","allowscriptacces","plugnspage"]}, object:{attribute:["classid","codebase"]}, param:{attribute:["name","value"]} }

  3. Universally override elements that the TinyMCE strips out by adding a list of elements to the glide.ui.html.editor.extended_valid_elements property.
    For example: adda[onclick|href|target|rel|media|hreflang|type|charset|name|rev|shape|coords|download|id|accesskey|class|dir|lang|style|tabindex|title]to the system property.

Related Links

Embed videos in HTML fields

Videos in the knowledge article are missing or unable to play


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.