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SLA calculations did not work as expected for Holiday schedule entries having the "Type" of "Time Off" - Support and Troubleshooting
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  • SLA calculations did not work as expected for Holiday schedule entries having the "Type" of "Time Off"
KB0746135

SLA calculations did not work as expected for Holiday schedule entries having the "Type" of "Time Off"


842 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

  • SLA Definition with a schedule continued to run even when there was a Holiday schedule entry on that day. Hence, task_sla record calculations are wrong.

Release

  • Jakarta Patch 7

Cause

The user has some SLA calculations which did not work as they would have expected with Holiday schedule entries having the "Type" of "Time Off".

Resolution

After some research, it was found that "Time Off", "Appointment", "Meeting", "Phone call", and "Task" are all relating to Resource Management. 

Here is the documentation which shows the same:

  • https://docs.servicenow.com/csh?topicname=t_AddEventsToYourCalendar.html&version=latest


This is further corroborated by a system property regarding the "Time off" type for Schedules - com.snc.resource_management.exclude_events_from_schedule ( ref: /nav_to.do?uri=sys_properties.do?sys_id=f0efacae9320220064f572edb67ffbb0 ).

It can be seen from the description field of the property that it describes what "resource event types which will be excluded from user's schedule to calculate available capacity and to avoid making resource allocations on the days having these events (time off, meeting, etc.)"

From this, it can be determined that "Time off", "Meeting", "Appointment", etc. are all options which can be included in the property value to better organize and manage a user's available capacity, and to avoid making resource allocations for the user on those days having these events.

For SLAs, please utilize the "Excluded" type, as it is recommended choice for excluding SLA calculations.


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