Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Business Rule "Close Parent if Required" is not working as expected. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Business Rule "Close Parent if Required" is not working as expected.
KB0746129

Business Rule "Close Parent if Required" is not working as expected.


2037 Views Last updated : Sep 21, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Request is not closing when requested items are closed.

Cause


Custom workflow 'Request for Access' setting State field. 

Resolution


The behavior seen is due to the setting State field not the Stage field in workflow 'Request for Access' . Notice the conditions in the business rule 'Close Parent if Required': 
current.stage.changes() && (current.stage=='complete' || current.stage=='Request Cancelled' || current.stage == "closed_incomplete" || current.stage=="closed_skipped") 

This is checking the Stage is set to 'complete' 'closed_incomplete' ect. However, the Set Value workflow activities in workflow 'Request for Access' is setting the State and is not updating the Stage value. Please reconfigure the custom workflow to update the stages as necessary. The other option here would be to create a custom business rule or customize business rule 'Close Parent if Required' to check State field.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.