Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
NOW-DSC-DOMAIN_TABLE_WRONG_PATH - Product Knowledge
  • >
  • Knowledge Base
  • >
  • Product Knowledge (Knowledge Base)
  • >
  • NOW-DSC-DOMAIN_TABLE_WRONG_PATH
KB0746101

NOW-DSC-DOMAIN_TABLE_WRONG_PATH


449 Views Last updated : Aug 28, 2023 public Copy Permalink
KB Summary by Now Assist
NOW-DSC-DOMAIN_TABLE_WRONG_PATH
SeverityError
Root Cause
  • Paths are replicated in data tables along with the reference to the domain (this is done to improve the speed of record queries).
  • The path changes when:
    • a domain reference changes, or
    • a domain structure changes.
  • These path changes must be replicated in the data tables that reference the changed domain.

ROOT CAUSE: When the update of the path fails or takes too long, the path in the data table will not match the path of the domain.

EffectThe effect of mismatched paths is that data that is expected to match the domain path but doesn't will not be visible to users in the domain. Additionally, this data may become visible to users not in the domain.
Corrective Action

Fix domain table sys_domain_path values:

  1. Determine which of the two attached scripts you will need:
    • To validate table data and fix any inconsistencies: Validate_and_Fix.txt
    • To simply validate data without fixing inconsistencies: Only_Validate.txt
  2. Ensure that you are in the global domain.
  3. Navigate to System Maintenance > Scripts - Background.
  4. Cut the script from the attachment file and paste it into Scripts - Background.
  5. Locate the TODO comment in the script code.
  6. On the line below the comment, replace INSERT_TABLENAME_HERE with the name of the domain-separated table on which to run the script.
  7. Click the Run script button.
  8. The script is complete when you see a message that starts with either:

Data validation successful

or

Data validation unsuccessful

 

 

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

Attachments

Attachments

  • Only_Validate.txt
  • Validate_and_Fix.txt

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.