Issue
Items from your order guides are missing. You have items defined in the "Rule Base" related list (on Order guide record) that are not showing up as expected.
Cause
The most likely issue is that the actual item referenced in the Rule is inactive.
Resolution
Click on the item in the "Rule Base" related list to check if inactive. Make active if needed, save, and retest. The item should now be showing in the Order Guide as expected for its rule.