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Symptoms

When the "i" icon of a reference field is clicked a popup view of the referenced record is displayed. However, the fields showing on this popup view is not the same ones configured on the sys_popup view of the form.

The sys_popup view of the referenced record displays as expected on Default view of the record but not on any other views (i.e. ess, Mobile).

Release

All releases

Cause

Missing associated sys_popup,name_of_view.

The sys_popup view by itself only works for the OOB "Default" view.

Resolution

Create a "sys_popup,name_of_view" for the referenced table (i.e. sys_user.do?sysparm_view=sys_popup,ess)

An example:

  • We'll be using incident record and caller_id reference field (which references sys_user)
  • Assume that sys_popup view already exists for sys_user
  • On an incident record that is using the OOB "Default" view when a user clicks on the "i" icon of the caller_id field the popup window will use the sys_popup view configured on sys_user
  • Now on the same incident record but this time it's using the "ess" view when a user clicks on the "i" icon of the caller_id field the popup window will NOT use the sys_popup view configured on sys_user and instead would be using other form views of sys_user
  • To make sure that the popup window uses the proper sys_popup view of sys_user when the incident record is using "ess" view the sys_user view needs to be configured as such:
    • sys_user.do?sysparm_view=sys_popup,ess
    • then modify the fields on this form view as appropriate

Additional Information

Reference field icon

Article Information

Last Updated:2019-04-08 01:43:42
Published:2019-04-05