Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to discover Pure Storage FlashBlades - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to discover Pure Storage FlashBlades
KB0745489

Unable to discover Pure Storage FlashBlades


2164 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

You will see multiple errors like:

"Active, couldn't classify, now finished"

when the Unix Classify MultiProbe is run, along with Unsupported shell, 'rbash', and probe parameter 'allow_unsupported_shells' is set to 'false'. Supported shells are tcsh, csh, ksh, sh, bash.

Cause

The shell 'rbash' is used during classification and is unsupported out of box.

Resolution

The 'allow_unsupported_shells' parameter must be added to all probes that run during the 'Unix - Classify' MultiProbe. 

This includes the following:

  • ESX - OS
  • UNIX - OS
  • F5 - OS
  • ZOS - OS
  • Pure blade rbash - OS

Note: The MID parameter mid.ssh.shells_supported is NOT required to resolve this issue.

Related Links

Pure Storage FlashBlade discovery


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.