Notifications

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Symptoms

Unable to grant access to CI Duplicate Remediation function without itil_admin role.

Cause

This is by design and hardcoded within ServiceNow. Therefore, there is no way to provide this capability without the itil_admin role.

Code Excerpt
12 <g2:evaluate var="jvar_user_has_permissions" expression="gs.hasRole('itil_admin')" />
13
14 <!-- Branch and display access denied message if needed -->
15 <j2:if test="$[jvar_user_has_permissions == false]" >
16 <!-- Common 'browser unsupported' message page -->
17 <g:inline template="cmdb_access_denied.xml"/>
18 </j2:if>

Additional Information

Remediate a de-duplication task

Article Information

Last Updated:2019-05-21 11:55:47
Published:2019-04-03