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Surveys are showing blank for end users in the portal - Support and Troubleshooting
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  • Surveys are showing blank for end users in the portal
KB0745473

Surveys are showing blank for end users in the portal


1517 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When the survey link is clicked, it just displays a blank page in the portal

Release


London

Cause


It is most probably caused due to the skipped London upgrades in the script include "SPSurveyAPI"

Resolution


Starting from London, the "one click survey" feature has been introduced, which when enabled in the survey definition, it would skip the survey intro page in the portal.

So the widget code is updated to check if the survey has "one click survey" enabled and it will skip/load the intro page accordingly.

The widget gets that information from the script include "SPSurveyAPI".

But the script include "SPSurveyAPI" has been customized and so it has skipped the London upgrades. Therefore, it does not provide the widgets with the information regarding the "one click survey".

So the widget code is not able to determine which page to show and therefore it displays the blank page.

To resolve the issue, please revert the script include "SPSurveyAPI" to the latest London version and then apply any customizations on top of it, if you like.

Additional Information


1. Please refer to this documentation for more information on "one click survey"
https://docs.servicenow.com/csh?topicname=c_SurveyServicePortal.html&version=latest


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