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Developer tab is not displayed in System Settings for admin user - Support and Troubleshooting
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  • Developer tab is not displayed in System Settings for admin user
KB0745206

Developer tab is not displayed in System Settings for admin user


3080 Views Last updated : Oct 1, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

A user who possesses the admin role cannot see the Developer tab in the System Settings popup

Release

All supported releases

Cause

When the High Security plugin is enabled in the instance, users can make certain user roles elevated by checking the Elevated Privilege checkbox in the sys_user_role record form. This option sets the roles to session-specific privileges.

Resolution

Uncheck the Elevated Privilege checkbox in the admin sys_user_role record to resolve the issue.

  1. Make sure that the High Security plugin is enabled.
  2. Navigate to the sys_user_role table.
  3. Search for and select the admin record or navigate to the following link:
  4. https://<instance-name>.service-now.com/nav_to.do?uri=sys_user_role.do?sys_id=2831a114c611228501d4ea6c309d626d
  5. Uncheck the Elevated Privilege checkbox.
  6. Save the record.
  7. Flush the cache and log in to the instance again after making this change.

Additional Information

Refer to the Elevated privilege roles product documentation which states: The use of elevated privilege on the admin role is not supported and may cause unexpected behavior.


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