Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
"Configuration Item" field in Problem record does not list the entire "Configuration Item" List as simialr to the "Configuration Item" field in "Incident" form - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • "Configuration Item" field in Problem record does not list the entire "Configuration Item" List as simialr to the "Configuration Item" field in "Incident" form
KB0744936

"Configuration Item" field in Problem record does not list the entire "Configuration Item" List as simialr to the "Configuration Item" field in "Incident" form


2058 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

"Configuration Item" lookup field in Problem record does not list the entire Configuration Item List as compared to the "Configuration Item" lookup field on Incident record.

Release

Any supported release. 

Cause

The "Configuration Item" reference field on task table had dictionary override setup for Problem table to have additional reference qualifier and hence due to this additional reference qualifier, the cmdb_ci field on problem form fires below query,

 SELECT ... FROM cmdb cmdb0 WHERE cmdb0.`sys_class_path` LIKE '/!!%' AND cmdb0.`operational_status` NOT IN (6) /*...*/

But the cmdb_ci field lookup on incident form fires below query as there is no reference qualifier set, 

 SELECT ... FROM cmdb cmdb0 WHERE cmdb0.`sys_class_path` LIKE '/!!%' /*...*/

This causes the difference between the "Configuration Item" lookup on Incident and Problem record.

Resolution

Review the dictionary override setup on "Configuration Item" field for "Problem" table and modify it as per the business requirement. 

Additional Information

Dictionary override

Reference Lookup field

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.