Issue
In forms, users are unable to personalize the columns of related lists.
Symptoms
Below are the steps to reproduce:
- Navigate to the form.
2. Notice the form view is not the Default one.
3. From the "hamburger menu"click on the "Toggle Domain Scope" option.
Otherwise, the "Domain Scope Expanded" message will be displayed after making changes in the Related List.
4. Go to any Related List.
5. Click on the gear iconand move some columns from "Available" to "Selected" and click OK.
*** Notice the form will be reloaded.
6. Re-visit the Related List and notice the added columns are not displayed.
If the Related List is opened in a New Window and the view for the list is set to Default, then the added columns will be displayed.
Facts
The potential impact discussed here is for instances with Domain Separation.
Release
Xanadu and previous
Cause
The following system property is set to true: glide.sys.domain.use_record_domain_for_processes
When this property is enabled, we use the record's domain for choosing which processes to run on any form. For lists, we use the user's session domain for picking the processes.
Resolution
Set the system property glide.sys.domain.use_record_domain_for_processes to false.
However, evaluate the requirements of the business and modify the value of this property accordingly.
Related Links
Review the following related KB article KB0716622.