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JDBC Import fails in Initiating the connection - Support and Troubleshooting
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  • JDBC Import fails in Initiating the connection
KB0744351

JDBC Import fails in Initiating the connection


1712 Views Last updated : Jan 28, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

JDBC Import fails with below Error:

MID Server reported error: Failed to init the JDBC connection. Check configuration

Release

All versions

Environment

Set up a JDBC Data Source via MID Server with or without specific Application scope which has Application Administration as Active.

Cause

Configuration issue of scope where it has Application Administration set to true on the sys_scope record and the ACL issue sys_data_source table.

Resolution

Deactivate 'Application administration' on the sys_scope record.

OR

If 'Application administration' is required to be Active. We will need to ensure that the READ ACLs against the 'sys_data_source' table has the role defined - 'x_<scope_name>.user' i.e. whatever is configured on the Application details so that the mid server user can access the sys_data_source table.

Additional Information

Ref Doc: Access control rules in application administration apps

Check system property: glide.security.scoped_administration.honor_global_acl If no scoped ACL rules are defined, application administration apps can inherit global ACL rules. By default, this property is enabled for new and upgraded instances.


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