Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to view "Toggle Domain Scope" UI Action in forms - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to view "Toggle Domain Scope" UI Action in forms
KB0744323

Unable to view "Toggle Domain Scope" UI Action in forms


1585 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

When user belongs to a domain different than the record's domain, system will show up "Toggle Domain Scope" form context UI action as shown in the below screenshot, However, none of the users were able to see "Toggle Domain Scope" option. This issue was occurring, though the user had "domain_expand_scope" role.

Release

Any supported release. 

Cause

  • In addition to granting user with "domain_expand_scope" role, system is looking for the system property "glide.sys.domain.use_record_domain_for_data".

Resolution

  • Please create a true | false type system property "glide.sys.domain.use_record_domain_for_data" and set it to true.
  • When this property is enabled, we use the record's domain for restricting the data visibility within a form. User's with appropriate role will see an UI Action to toggle domain scope between record's domain and user's session domain.

Additional Information

Domain scope

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.