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Attachments in the knowledge article are not visible in "kb_article_view" page of knowledge portal. - Support and Troubleshooting
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  • Attachments in the knowledge article are not visible in "kb_article_view" page of knowledge portal.
KB0744245

Attachments in the knowledge article are not visible in "kb_article_view" page of knowledge portal.


7128 Views Last updated : Oct 4, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Attachments in the knowledge article are not visible in the "kb_article_view" page of the knowledge portal. But the attachments are visible in the articles when opened in native UI(non-portal) and also visible in the "kb_article" page of the Service portal.

Release

Knowledge portal

Cause

On the kb_article_view page, there is a separate widget "Knowledge Attachments" to show the attachment of the article. This widget collects the data such as "tableName", "article_sys_id" from the widget "Knowledge Article Content" widget (which displays the article body). When the user is using the customized "Knowledge Article Content" widget and the "tableName" or the "article_sys_id" is not defined in the same custom widget, the attachment wouldn't be visible.

Resolution

Declare and define the tableName/article_sys_id in the custom 'Knowledge Article Content' widget.


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