Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Unable to view all sys_user_preferences records as an Admin, seeing security constraints message - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Unable to view all sys_user_preferences records as an Admin, seeing security constraints message
KB0743902

Unable to view all sys_user_preferences records as an Admin, seeing security constraints message


884 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms

Admin unable to view all sys_user_preferences records seeing security constraints message.

Cause

Log in as an admin

  1. Type in the navigator filter sys_user_preferences.list
  2. You will be unable to view all records.
    • An error message states: "Number of rows removed from this list by Security constraints: #"
  3. Elevate roles to security_admin
  4. Still unable to view records

Resolution

The System property "glide.security.admin.override.accessterm" is set to false, while it's true in a base system. See: Evaluate the admin override at the access level

The ACL: "sys_user_preference" /read is blocking your access even though you have the admin override it is being ignored due to the system property being set to false.

If your business process allows, you should set "glide.security.admin.override.accessterm" to true so the overrides in the ACLs for the admins would work.

Additional Information

The "security_admin" role cannot be inherited, it must be added by a user that has it as not inherited like the "admin" account. We recommend taking it out of the group and adding the role to each user that has an admin account that you want to have the security_admin role from an account that does not have it inherited from a group like the "admin" account.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.