Issue
Symptoms
Meta search not working on Service Portal
Release
All Supported
Environment
Service Portal
Cause
In the ts_word table, which contain the indexed words, there are over 500 words that start with one of the search words. Out of Box we have property "glide.ts.max_wildcard_expansion", which sets the maximum number of matches for a wildcard term that are allowed as unambiguous. Because, there are over 500, the search returns no results.
Resolution
Modify property and set to a higher threshold.
Additional Information
https://docs.servicenow.com/csh?topicname=set-global-text-search-properties.html&version=latest