Issue
Symptoms
Catalog Items are visible in "Popular Items" widget but they should not be showing up or be searchable
Release
All Supported
Environment
Service Portal
Cause
Unless restricted by a Role or User Criteria, the item will show up.
Resolution
Apply user criteria to the individual item. If needed, install the "Service Portal User Criteria Support" plugin
Additional Information
https://docs.servicenow.com/csh?topicname=user-criteria.html&version=latest