Issue
Symptoms
The user will have access to sysapproval_approver record and can approve from the ITIL view(non portal). But when the same user tries to view the record in Approval wodget, it struck on 'Loading approval' in Service portal.
Release
ALL
Environment
Service portal
Cause
As the users don't have access to the record(RITM, change request etc.,) they are trying to approve, the Approvals widget failed to load the approvals.
Resolution
By providing the access(creating an ACL or editing 'Incident Query' business rule) to the approval, the user will be able to see and approve the approvals.