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Different ways on how to restore a deleted field - Support and Troubleshooting
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KB0727965

Different ways on how to restore a deleted field


9651 Views Last updated : Jul 24, 2025 public Copy Permalink English (Original)
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KB Summary by Now Assist

Issue

The information provided in this KB details how to restore a deleted field. Attached in this KB will be a link to Product Documentation that goes more into depth on the new features which makes the process of undeleting records much more simple. Product Documentation: "Use the Deleted Records Module to restore a deleted record".

Cause

The manual deletion of a field is when a user goes to the field record and deletes the record themselves either with the Delete button or with a script.

Resolution

If someone manually deletes a field and there is no attached data associated with that field, there are three options to consider to restore these fields:

  1. The Deleted Records module can be used to restore a deleted record. See Use the Deleted Records module to restore a deleted record
  2. Recreate the field that was deleted
  3. There is a sys_metadata_delete (Deleted Applications File) table that may contain the missing data for the deleted field. You can simply find the records that were deleted and restore the files for that record.

Example: A user/admin creates a field called VIP Flag. After creation, the user/admin realizes that they no longer need the field and decided to delete it. The steps to restore through this procedure is as follows:

  1. Go to sys_metadata_delete.list (Deleted Applications File) in the Filter Navigator
  2. Query where name = 'Display name of deleted field' (In this case it is VIP Flag) and click on the Dictionary Entry record



  3. Click on Restore File



  4. Confirm the restoration of this deleted field.

 Note: If someone manually deletes a field and there is attached data associated with that field, contact Technical Support.

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