Issue
Under the MID server record in the "MID server issues" tab you see the following error:
"Could not decrypt file discovery whitelist after sync".
Release
All
Cause
Cause 1:
- This happens when the MID server tries to decrypt files that are trying to be synced from the instance before it had a chance to be validated.
Cause 2:
- The issue is caused by the fact that the instance will return nothing if the plugin "com.snc.discovery.file_based_discovery" doesn't have a license and the code on the mid server doesn't handle the error correctly so that the error message is misleading.
- Please take a look at the sys_web_service script GetMIDInfo. When MID server starts, it will send a SOAP request to instance asking for updating file discovery allow-list. The request will be handled by the following function in GetMIDInfo:
function updateFileDiscoveryWhitelist() {
Since there is no license for this, it returns a response with an **empty** midInfo and the MID server will see that as a mid server issue, this can be ignored.
var havelicense = sn_lef.GlideEntitlement.hasBetaLicenseForApp('com.snc.discovery.file_based_discovery');
if (!havelicense) {
response.midInfo = null;
return;
}
var agent = request.agent;
var doc = MIDServerInfoAccessor.updateFileDiscoveryWhitelist(agent);
response.midInfo = doc;
}
Resolution
Cause 1:
- Make sure the MID server is validated
- Manually resolve the Issue on the instance
- Restart the MID Server, the issue should not come back anymore
Cause 2:
- On the script comment out the license verifying code to work around it. (Please note the update to this file during platform upgrades might be skipped)
OR - Add a business rule to ecc_agent_issue (MID server issues) table to automatically change the state of that particular error message to 'Resolved' so it does not appear on the MID issue list as a 'New' issue any longer.
If the above performed and still have some issues, please follow the below
- Stop the mid server from the host machine, deleted the Keystore folder and started the MID- server service.
- The Keystore folder will be created automatically
- Now login to the ServiceNow instance and validate the mid server
- Wait for 2-5 minutes and the error will disappear from "MID SERVER ISSUE TAB"