Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Auto-complete does a 'starts with' search instead of 'contains' when the system property 'glide.ui.goto_use_contains' is set to true for reference fields. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Auto-complete does a 'starts with' search instead of 'contains' when the system property 'glide.ui.goto_use_contains' is set to true for reference fields.
KB0727722

Auto-complete does a 'starts with' search instead of 'contains' when the system property 'glide.ui.goto_use_contains' is set to true for reference fields.


1681 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

 

Symptoms


For a reference field on a form, searching for a value and clicking on reference lookup, the search takes 'Starts With' instead of 'Contains'.

(Eg : For assignment group field on incident record, on entering fo, two valid results are shown. Clicking on reference lookup shows Name starts with 'fo' and not Name contains 'fo'). 

 

 

Release


Any supported release

Cause


The system property 'glide.ui.goto_use_contains' controls the search in the list view and not reference lookup.

Resolution


A system level user preference with the format <table_name>.autocomplete.contains with value true has to be created for contains search to work on reference fields.

For assignment group field, User Preference with below details has to be created:

Name :sys_user_group.autocomplete.contains

Type : true|false

Value : true

System : true

 

Once the user preference is created, make sure to clear the instance cache (by doing cache.do) and login back to the instance.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.