Issue
Symptoms
Submit button is be missing from the Time Card Portal after London Upgrade.
Release
London
Cause
Before London, the "Submit" button is in Time Card Portal Header widget. In London, it is moved to Time Card Portal Main Container widget.
If the Customer has customized Time Card Portal Main Container it will be skipped in the upgrade resulting in the issue.
Resolution
Attached is the OOB Time Card Portal Main Container, Importing and customizing the Cloned widget will resolve the issue.
If the issue exists after Importing, navigate to the Time Card Portal Main Container in the Portal and in the Angular Provider Related list add TimeCardPortalService.