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Skipped records discrepancies post-upgrade - Support and Troubleshooting
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KB0726987

Skipped records discrepancies post-upgrade


2073 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Generally speaking, if you have customized an OOB record, then it will be skipped during the upgrade. This is because the upgrade process is designed to only update the standard, unmodified components. The number of skipped changes after an upgrade may differ from production (prod) to sub-production (sub-prod) environments, or even between different sub-prod environments. This discrepancy arises due to the fact that the data in these instances are not completely in sync, which can lead to inconsistencies in the upgrade process.

This situation can occur for two primary reasons:

  1. A full clone of the production environment was not completed prior to the upgrade. A full clone is necessary to ensure that all data and configurations are identical between the production and sub-production environments. Without this, the upgrade process may not accurately reflect the changes made in the production environment.
  2. Changes were made within the sub-production instance after the clone and before the upgrade. Any modifications made after the clone but before the upgrade can cause discrepancies between the production and sub-production environments, leading to skipped changes during the upgrade process.

 

Cause

  1. One reason there is a large number difference between instances after an upgrade is because a full clone was not performed prior to the upgrade.
  2. Another reason the numbers may slightly differ is due to the number of updates that are made to the instance after the clone was done and before the relative upgrades. It may be worth checking to see if there are any sys_update_xml records created after the clone and before the upgrade took place.

Resolution

A full clone, excluding nothing, is necessary for optimal upgrade evaluation. Here are some things to consider when noticing differences in 'Skipped Changes' numbers:

  • Review the clone history and check if the 'Exclude tables specified in Exclusion List', 'Exclude audit and log data' and 'Exclude large attachment data' options were all checked. These need to be unchecked during a full clone.
  • If they have not been fully cloned, you can never be certain that one instance is an accurate representation of another, and you may see discrepancies in the 'Skipped Changes' numbers.
  • In the case of looking at two sub-production with this mismatch in numbers, ensure if the same backup of prod was re-used or if a new backup was used for each clone.

Over the course of the period between clone and upgrade, development could be taking place and changes could have been moved through these instances, and it's almost impossible for the two to remain perfectly in-sync. All of this has an impact on the Customizations Unchanged and Skipped Changes to Review related lists. Make sure to review these related lists after every upgrade.

The key indicator is that the Upgrade Details list shows the same number in both instances, confirming identical updates.

Related Links

Skipped Changes to Review related list

Customizations Unchanged related list

 

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