Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Some large attachments are not included in emails when exporting a report - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Some large attachments are not included in emails when exporting a report
KB0726968

Some large attachments are not included in emails when exporting a report


3827 Views Last updated : Jun 13, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

When exporting a report containing a large attachment, like a .csv file larger than 25 MB, the following dialog box displays with a Mail it option.

Dialog box showing mail it option for email export

However, selecting the Mail it option does not include the expected attachments. 

Cause

The failure to include some attachments is due to the attachment file size and the outbound email attachment size limitations of the ServiceNow infrastructure.

Resolution

For exports with large file attachments, instead of selecting the Mail it option, download the reports by selecting Wait for it.

Alternatively, you can increase the value of the system property by updating this record: glide.email.outbound.max_total_attachment_size_bytes.

Note: If using the ServiceNow mail infrastructure to send these emails, there is a hard limit of 25 MB that cannot be changed. This limit includes the total size of the email, including body and all attachments. You can use your own email infrastructure if you need to send attachments larger than 25 MB.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

Attachments

Attachments

  • Pasted image.png

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.