Issue
When exporting a report containing a large attachment, like a .csv file larger than 25 MB, the following dialog box displays with a Mail it option.
However, selecting the Mail it option does not include the expected attachments.
Cause
The failure to include some attachments is due to the attachment file size and the outbound email attachment size limitations of the ServiceNow infrastructure.
Resolution
For exports with large file attachments, instead of selecting the Mail it option, download the reports by selecting Wait for it.
Alternatively, you can increase the value of the system property by updating this record: glide.email.outbound.max_total_attachment_size_bytes.
Note: If using the ServiceNow mail infrastructure to send these emails, there is a hard limit of 25 MB that cannot be changed. This limit includes the total size of the email, including body and all attachments. You can use your own email infrastructure if you need to send attachments larger than 25 MB.