Issue
- When Quick Discovery runs using a Pattern (e.g. Windows OS - Server).
- Discovery Status completes but the Devices tab shows Completed Activity: "Classified" and Current Activity "Identifying"
- In the Discovery Log, Error "Failed Exploring CI Pattern, Pattern name: <pattern_name>. Please Check Pattern Log Press Here".
Pattern Logs:
Identity Rule for table [table_name] missing Lookup Rule for class [lookup_table_name]
Release
Pre Orlando.
Cause
Lookup rule returned in payload, however no matching lookup rule in identifier.
Resolution
- Check on the CMDB Identifiers, "Discovery Definition > CI Identification > Identifiers".
- Check on the Identifiers that Applies to <table_name>.
- See if there are any custom Identifier created that Applies to the table affected.
- If there is, either
- de-activate the custom Identifier
- add identifier lookup rule (see links on Additional Information section of this KB)
Note: "Configuration > CI Class Manager" can be used to determine what identifier is used for a table