Issue
Symptoms
Catalog Item is not displayed when opened in Service Portal catalog
Release
All Supported
Environment
Service Portal
Cause
"SC Catalog Item" widget is not on the page
Resolution
Open the Designer, remove any unwanted widgets and add the "SC Catalog Item" widget to the page.
Additional Information
https://docs.servicenow.com/csh?topicname=t_ConfigureAPage.html&version=latest