Issue
Symptoms
Unable to query Microsoft Windows Active Directory when running "Query AD" workflow activity. The exact is shown below:
Fault Description:
com.snc.automation_common.integration.exceptions.NoSuitable
Unable to find any validated MID Server based on status (degraded), and application: Orchestration, and IP Range
Cause
MID Server does not have an IP Range and does not have PowerShell capability set.
Resolution
1. Go to https://YOUR_INSTANCE.service-now.com/ecc_agent_list.do
2. Find the MID Server that your workflow activity is using and open the record.
3. Find the related list named "IP Ranges"
4. Click "Edit" and double click "ALL" or an IP range on the left that meets the criteria of your workflow.
This will move "ALL" or your range from the left to the right of the slush bucket. Click "Save".
5. Run the workflow again successfully.
Note:
If above is not working, and target is FQDN instead of IP Address, then check Orchestration > MID Server Configuration > MID Server Properties, make sure "Default MID Server to use for Orchestration Activities" field is populated with valid MID server name.
Orchestration is relying on default MID server that's set in "Orchestration MID Server Properties" to resolve target FQDN.
Alternatively you may create a cmdb_ci_dns_name entry for the target FQDN and manually add IP address.