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MID Server Issue


In the MID Server record, related list "MID Server Issues" shows the error below:

"A MID Server with a duplicate name of sys_id was prevented from connecting. Install path C:\<Mid Server path>. The issue must be manually resolved."

 

Symptoms

  • MID Server version is not compatible to the current instance version.
  • MID Server status is "UP" but not processing the "output" payload in the ECC Queue. (e.g "Execute the Grab MID logs").
  • MID Server status sometime shows "DOWN".
  • Found in agent logs:

02/18/19 07:59:55 (994) StartupSequencer WARNING *** WARNING *** Encountered error: [An active MID Server with a duplicate name detected.] in ensuring agent record on the instance. Retry...
02/18/19 07:59:55 (994) StartupSequencer Waiting to retry in 5 minutes. Attempt 1 of 3.
02/18/19 08:04:56 (969) StartupSequencer WARNING *** WARNING *** Encountered error: [An active MID Server with a duplicate name detected.] in ensuring agent record on the instance. Retry...
02/18/19 08:04:56 (969) StartupSequencer Waiting to retry in 5 minutes. Attempt 2 of 3.
02/18/19 08:09:57 (928) StartupSequencer WARNING *** WARNING *** Encountered error: [An active MID Server with a duplicate name detected.] in ensuring agent record on the instance. Retry...
02/18/19 08:09:57 (928) StartupSequencer Waiting to retry in 5 minutes. Attempt 3 of 3.
02/18/19 08:14:58 (402) StartupSequencer WARNING *** WARNING *** Socket error
02/18/19 08:14:58 (402) StartupSequencer SEVERE *** ERROR *** getRecords failed (Socket error)
02/18/19 08:15:02 (068) StartupSequencer SEVERE *** ERROR *** Unable to connect to instance at https://<instance-name>.service-now.com/ (Socket error)
02/18/19 08:15:03 (004) StartupSequencer WARNING *** WARNING *** Encountered error: [An active MID Server with a duplicate name detected.] in ensuring agent record on the instance. Retry...
02/18/19 08:15:04 (205) StartupSequencer Stopping MID Server due to exceeding retry attempts.

  • MID Server host still have a lot of available space.

 

Cause


  • There's a duplicate MID Server service running in the MID Server host that points to the same MID Server installation folder (service). 

OR

  • The MID Server record in the instance might be corrupted.

 

Resolution


  • If duplicate MID Server service exists, it needs to be deleted. Please refer to KB0743043 on how to remove the MID Server service.

OR

  • To remove the MID Server Issue in the related list of the MID Server record, open the link and set the state to "Resolved", then Save.

OR

  • Stop the MID Server service in the MID Server Host.
  • Delete the MID Server record from the instance.
  • Start the MID Server service in the MID Server Host. (This will create a MID Server record in the instance).
  • Wait for the MID Server to status be UP again ("Upgrading..." will show if the MID Server is auto-upgrading).
  • Validate the MID Server.

Article Information

Last Updated:2019-03-08 03:33:30
Published:2019-03-08