Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Where to find SAMP plugin related files (skipped, upgraded, etc) after the plugin activation and how to revert them to OOB - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Where to find SAMP plugin related files (skipped, upgraded, etc) after the plugin activation and how to revert them to OOB
KB0726511

Where to find SAMP plugin related files (skipped, upgraded, etc) after the plugin activation and how to revert them to OOB


6726 Views Last updated : Oct 10, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Once SAMP or its related plugins are activated, the administrator may receive an email for reverting the customization. It may be hard to find where these skipped files are in the instance, to validate and revert them to out-of-box. This article describes how you can find the list of skipped files related to SAMP related plugins and their dependent plugins.

Release

Since Madrid

Cause

The module Revert Customizations is under the application Software Asset's module Administration:

Application Navigator >> Software Asset >> Administration >> Revert Customizations

This page provides the list of all customization files that can be review and reverted accordingly:

Resolution

For reverting files to OOB:

Method#1: Select the list of files/all skipped ones and select the bottom Actions menu and choose "Revert to Base System".

Method#2: Sometimes you may not see the UI Action "Revert to Base System", due to the instance having possibly been cloned, so losing their base files. In these situations follow the below steps:

  • Go to 'sys_update_version' table list view and search for this file.
  • Open the latest file (by sorting it z-a on Recorded at) and compare the contents of it with the source code and if the contents match, revert to this file.
  • Then mark this file as 'reverted' in Upgrade history.

 

 

 

Method #3: Contact ServiceNow technical support to run some revert scripts to revert all these related files to OOB. NOTE: SN requires customer approval for running this revert scripts in the "Scripts - background".

Validation of reverted files:

  • Immediately after you revert the files, follow the below procedure to validate the file reversion.
  • Remember to note the files numbers before reverting the skipped files (SAMP-Plugin-Activation-Skipped-Files).
  • Copy the URL below and replace the <<instance_name>> with your instance name, open it and validate the count is the same as previously noted count: https://INSTANCE_NAME.service-now.com/sys_upgrade_history_log_list.do?sysparm_query=sys_updated_onONLast%2030%20minutes@javascript:gs.beginningOfLast30Minutes()@javascript:gs.endOfLast30Minutes()%5Esys_updated_by%3Djavascript:gs.getUserID()%3B&sysparm_view=

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.